Ace-T's Blog 내 검색 [네이버 커넥트 이웃 합니다~^-^/ 요청 大 환영~~]

java.lang.IllegalArgumentException: At least one base package must be specified

OpenSource/Mybatis&Ibatis 2013.10.08 11:43
[Good Comment!!, Good Discussion!!, Good Contens!!]
[ If you think that is useful, please click the finger on the bottom~^-^good~ ]
by ace-T

 

오류내역

java.lang.IllegalArgumentException: At least one base package must be specified


상 황 :  mybatis의 MapperScannerConfigurer를 사용하고 있는데 아래와 같이 basePackage의 value값에

""로 셋팅하였을 때 발생 한다.

<bean id="cmnMapper" class="org.mybatis.spring.mapper.MapperScannerConfigurer">

<property name="basePackage" value="" />

<property name="sqlSessionFactoryBeanName" value="cmnSqlSessionFactory" />

</bean>


해결책 dao패키지를 최소한 하나 넣어주면 된다. 오류내역처럼~

At least one base package must be specified


  - 끝 - 

저작자 표시 비영리 변경 금지
신고

acet 박태하가 추천하는 readtrend 추천글!

설정

트랙백

댓글

:::: facebook을 이용하시는 분들은 로그인 후 아래에 코멘트를 남겨주세요 ::::

티스토리 툴바