es 버전이 낮으면..

2021. 6. 27. 19:28OpenSource/ElasticSearch

반응형
주저리

es버전..1.2.1 완전 오래된..버전을 사용하면..
공용으로 사용하는 spark 2.4.5 / scala 2.12 / elastic lib 버전 문제로 온갖 삽질 다함...

es 버전을 못올리는 상황이라면?
공용 spark쪽 사용 X
es lib를 버전업 못한다면 자체 개발 -> springboot  + springdata + elasticsearch로 개발

으악! 이것도 역시나 버전문제 발생..

그래서 방향 다시 틀었다.

REST api를 curl로 찔러서 파일로 다운.
이 파일을 자바에서 처리 하는걸로!

운영업무에 있어서 버전관리가 가장 큰 문제구나..

 

 

반응형
LIST